WordPress更新后提示需要升级数据库的解决方法

WordPress程序会不定期更新,为了维护网站安全,我们应及时进行版本升级。但有时在升级WordPress后,登录后台时会提示“需要升级数据库”的操作界面。出现这种情况主要是因为WordPress升级版本时,可能某些数据库中的表或字段有了增删或功能更新,这时可按照页面提示完成数据库升级操作。

点击页面上的“升级WordPress数据库”按钮后,系统会自动开始升级数据库,我们耐心等待其操作即可。但有时也会遇到点击升级数据库以后又提示:无需升级,您的WordPress数据库已经是最新的了,然后再次尝试登录 wp-admin,还是出现相同的“需要升级数据库”的消息,并且无法继续访问管理面板。

出现这种现象的用户大多是因为启用了Memcached缓存,在wp-content文件夹有object-cache.php文件,这是造成缓存无法登录的主要原因。

解决方法

打开WordPress的wp-content文件夹,找到object-cache.php文件,对其进行重命名或删除操作。或者重启Memcached服务,如果此时无法登录到服务器,我们可以安装WP Memcached Manager插件,清空下Memcached缓存。然后重新访问后台管理页面,这时会发现能正常登录到WordPress后台了。

为了使WordPress网站获得更好的性能,加快访问速度,我们在选择托管提供商时,可优先考虑租用经过性能优化的BlueHost主机、Hostinger主机等。

更多:《WordPress主机购买推荐》

未经允许不得转载:主机迷 » WordPress更新后提示需要升级数据库的解决方法