宝塔面板服务器缺少sg11扩展安装支持ixed.5.6.lin组件方法

宝塔面板服务器缺少sg11扩展怎么安装?这个问题是昨天下午的时候网友提供的他在迁移网站的时候。是将腾讯云服务器迁移到腾讯轻量服务器的时候,网站数据都正常,但是小程序无法访问有出现报错提示。或者,很多小伙伴们安装微擎模块就会遇到现在超级牛逼的sg11加密,这个时候就需要安装sg11扩展,如果没有安装可能会出现缺少”ixed.5.6.lin”组件的情况!

PHP script ‘/www/wwwroot/******/addons/fy_lessonv2/inc/mobile/index.php’ is protected by SourceGuardian and requires a SourceGuardian loader ‘ixed.5.6.lin’ to be installed.

1) Click here to download the required ‘ixed.5.6.lin’ loader from the SourceGuardian site

2) Install the loader to /www/server/php/56/lib/php/extensions/no-debug-non-zts-20131226

3) Edit /www/server/php/56/etc/php.ini and add ‘extension=ixed.5.6.lin’ directive

4) Restart the web server

从信息中可以看到,是当前的服务器环境缺少’ixed.5.6.lin’组件。因为他采用的宝塔面板整体迁移,他只是迁移到数据,服务器的配置软件是没有办法一起迁移的,除非是用镜像迁移。

所以,当前的服务器中安装 “ixed.5.6.lin”即可。

218849c4cea31675d6651e1c004af14f

操作步骤:

软件管理→启动的PHP版本服务→设置→安装扩展,选择sg11 脚本加密 php代码混淆加密!

如果是非宝塔面板,比如windows下,那就需要改php.ini文件:

打开php.ini大约在850行左右在同类型的参数下再添加一条 extension=ixed.5.4.win,保存之后,然后重启一下服务器即可!

这样安装SG11之后,PHP代码混淆加密模式,就可以解决问题。我们刷新小程序,看到他的网站问题全部解决。

未经允许不得转载:便宜主机网 » 宝塔面板服务器缺少sg11扩展安装支持ixed.5.6.lin组件方法

赞 (0)